Страница 2 из 2

Re: Проблема с запуском примеров на стенде

СообщениеДобавлено: 10 янв 2011, 19:48
h0rr0rr_drag0n
Нет, просто на 64-битных версиях Линукса m3p запускался и вылетал вроде бы с такой же ошибкой как и у вас. Думал, что и здесь может быть та же самая причина... :(

Re: Проблема с запуском примеров на стенде

СообщениеДобавлено: 11 янв 2011, 21:02
Alibaba
Я только что нашел проблему с переходником com<->usb. Он не работает хотя в диспетчере показывает это устройство. Я подключал стенд прямо к настолному компьютеру и программа сразу работала. Очень рад :D . Спасибо вам большое за помощь! После обсуждения я много разобрался.

Re: Проблема с запуском примеров на стенде

СообщениеДобавлено: 19 май 2012, 23:49
son-leta
Здравствуйте! У меня тоже возникли проблемы с запуском примеров. Буду благодарна за помощь.
Ситуация такая. Изначально в стенде был прошит загрузчик HEX-202, который я заменила на UL3. Вроде бы всё прошло успешно, надпись на дисплее изменилась на "SDK 1.1 Waiting...". Но при попытке залить тестовую программу стенд не работает (светодиоды никак не реагируют), скриншот прилагается. Судя по надписям на экране, загрузчик как будто HEX-202. Не понимаю, какой теперь в стенде загрузчик и как что-нибудь туда загрузить. Заранее спасибо.
1.jpg
1.jpg (64.67 Кб) Просмотров: 10227

Re: Проблема с запуском примеров на стенде

СообщениеДобавлено: 21 май 2012, 20:12
DinKa
  1. Каким образом Вы заменили загрузчик в стенде (последовательность действий)?
  2. Каким образом загружаете тестовую программу (последовательность действий)?
  3. Что выводится в терминал после включения/перезапуска стенда? Для этого наберите в командной строке "make term" и включите/перезапустите стенд.

Re: Проблема с запуском примеров на стенде

СообщениеДобавлено: 21 май 2012, 22:56
son-leta
Загрузчик заменяла так:
1. Включила стенд (при включении кстати у меня динамик не пищит и светодиоды не моргают, как пишут!), загорелась лампочка питания и надпись "SDK 1.1 Waiting..." (не в первый раз уже пробовала прошить).
2. Замкнула JP1 (просто обмотала проволокой - это же нормально?)
3. Нажала reset.
4. Запустила файл upload.bat, скачанный из материалов. У меня так же COM-1.

Запуск программы:
1. Сняла перемычку.
2. Скачала тестовую программу (светодиоды test_led). Скомпилировала с помощью make. Появились файлы test_led.hex и test_led.bin.
3. Загрузила с помощью make load. Получила то, что на предыдущем скриншоте, стенд никак не реагирует.

Терминал

Re: Проблема с запуском примеров на стенде

СообщениеДобавлено: 22 май 2012, 13:13
DinKa
В случае работы загрузчика UL3 в терминал после включения/перезапуска стенда должно выводиться что-то типа:
Код: Выделить всё
UL-0.0.1
m.m.m.m.m.m.m.m.m.

Чем закончился процесс смены загрузчика с HEX-202 на UL3 (что выводится в терминал)?
Попробуйте поменять коммуникационный кабель RS-232, COM-порт.

Re: Проблема с запуском примеров на стенде

СообщениеДобавлено: 22 май 2012, 22:17
son-leta
Процесс загрузки и вид терминала после на скриншоте. Оказывается, у меня в стенде AduC842 (видно на картинке), а не AduC812! Это что-то меняет (ушла читать) ?
Наверное, с RS-232 и COM-портом всё в порядке, иначе бы он не писал, что канал открыт?
.m.m.m.m.m у меня в терминал ни разу не выводилось

Re: Проблема с запуском примеров на стенде

СообщениеДобавлено: 24 май 2012, 10:52
kluchev
son-leta писал(а):Процесс загрузки и вид терминала после на скриншоте. Оказывается, у меня в стенде AduC842 (видно на картинке), а не AduC812! Это что-то меняет (ушла читать) ?
Наверное, с RS-232 и COM-портом всё в порядке, иначе бы он не писал, что канал открыт?
.m.m.m.m.m у меня в терминал ни разу не выводилось


Да, меняет и очень сильно. Чуть позже выложу PDF с отличиями. Главных отличий два:
1. Программы можно сразу загружать во FLASH штатным загрузчиком;
2. Стартовый адрес для программы не такой, как у ADuC 812.

Re: Проблема с запуском примеров на стенде

СообщениеДобавлено: 24 май 2012, 11:23
son-leta
Один pdf с отличиями я скачала с сайта и прочитала. После этого пыталась менять стартовый адрес: вместо T_RAM 0x2100 писала T_FLASH 0x0000, но ничего не работает, и почему-то загорается один светодиод (признак ошибки?). Но ведь штатный загрузчик я уже видимо затёрла, как его теперь восстановить?)

Re: Проблема с запуском примеров на стенде

СообщениеДобавлено: 27 май 2012, 20:15
son-leta
На форуме нашла только HEX202 для AduC842. Всё-таки есть ли возможность восстановить штатный загрузчик?

Re: Проблема с запуском примеров на стенде

СообщениеДобавлено: 28 май 2012, 13:11
DinKa
Посмотрите Windows Serial Port Downloader, описание в конце страницы Development Tools, точнее SOFTWARE TOOLS UPDATES FOR ADUC800-SERIES (8052-CORE).

Re: Проблема с запуском примеров на стенде

СообщениеДобавлено: 31 май 2012, 10:30
son-leta
Спасибо! Всё же прошила HEX-202, и работаю с ним через t2 пока. Главное, что стенд заработал!